What’s Vulnerable › Vulnerabilities
CVE-2023-35928: Nextcloud user scoped external storage can be used to gather credentials of other users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-274
Description
Nextcloud Server is a space for data storage on Nextcloud, a self-hosted productivity playform. In NextCloud Server versions 25.0.0 until 25.0.7 and 26.0.0 until 26.0.2 and Nextcloud Enterprise Server versions 19.0.0 until 19.0.13.9, 20.0.0 until 20.0.14.14, 21.0.0 until 21.0.9.12, 22.0.0 until 22.2.10.12, 23.0.0 until 23.0.12.7, 24.0.0 until 24.0.12.2, 25.0.0 until 25.0.7, and 26.0.0 until 26.0.2, a user could use this functionality to get access to the login credentials of another user and take over their account. This issue has been patched in Nextcloud Server versions 25.0.7 and 26.0.2 and NextCloud Enterprise Server versions 19.0.13.9, 20.0.14.14, 21.0.9.12, 22.2.10.12, 23.0.12.7, 24.0.12.2, 25.0.7, and 26.0.2. Three workarounds are available. Disable app files_external. Change config setting "Allow users to mount external storage" to disabled in "Administration" > "External storage" settings `…/index.php/settings/admin/externalstorages`. Change config setting to disallow users to create external storages in "Administration" > "External storage" settings `…/index.php/settings/admin/externalstorages` with the types FTP, Nextcloud, SFTP, and/or WebDAV.
Affected products
- Nextcloud Server: from 19.0.0 before 19.0.13.9; from 20.0.0 before 20.0.14.14; from 21.0.0 before 21.0.9.12; from 22.0.0 before 22.2.10.12; from 23.0.0 before 23.0.12.7; from 24.0.0 before 24.0.12.2 — fixed in 19.0.13.9, 20.0.14.14, 21.0.9.12, 22.2.10.12, 23.0.12.7, 24.0.12.2
How to fix
Upgrade to a fixed version: Nextcloud Server 19.0.13.9, 20.0.14.14, 21.0.9.12, 22.2.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-637g-xp2c-qh5h
- https://github.com/nextcloud/server/pull/38265
- https://hackerone.com/reports/1978882
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-637g-xp2c-qh5h
- https://github.com/nextcloud/server/pull/38265
- https://hackerone.com/reports/1978882
Get alerted when CVE-2023-35928 or the next vulnerability affects your stack