What’s Vulnerable › Vulnerabilities

CVE-2023-35941: Envoy vulnerable to OAuth2 credentials exploit with permanent validity

Description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.

Affected products

How to fix

Upgrade to a fixed version: envoyproxy envoy 1.23.12, 1.24.10, 1.25.9, 1.26.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-35941 or the next vulnerability affects your stack