What’s Vulnerable › Vulnerabilities
CVE-2023-35942: Envoy's gRPC access log crash caused by the listener draining
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-416
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, gRPC access loggers using listener's global scope can cause a `use-after-free` crash when the listener is drained. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, disable gRPC access log or stop listener update.
Affected products
- envoyproxy envoy: from 1.23.0 before 1.23.12; from 1.24.0 before 1.24.10; from 1.25.0 before 1.25.9; from 1.26.0 before 1.26.4 — fixed in 1.23.12, 1.24.10, 1.25.9, 1.26.4
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.23.12, 1.24.10, 1.25.9, 1.26.4. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-69vr-g55c-v2v4
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-69vr-g55c-v2v4
Get alerted when CVE-2023-35942 or the next vulnerability affects your stack