What’s Vulnerable › Vulnerabilities
CVE-2023-35971: Unauthenticated Stored Cross-Site Scripting (XSS) in ArubaOS Web-based Management Interface
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the ArubaOS web-based management interface could allow an unauthenticated remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the interface. A successful exploit could allow an attacker to execute arbitrary script code in a victim's browser in the context of the affected interface.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.5.4.0 before 8.6.0.21; from 8.7.0.0 before 8.10.0.7; from 8.11.0.0 before 8.11.1.1; from 10.4.0.0 before 10.4.0.2 — fixed in 10.4.0.2, 8.10.0.7, 8.11.1.1, 8.6.0.21
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.2, 8.10.0.7, 8.11.1.1, 8.6.0.21. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-008.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-008.txt
Get alerted when CVE-2023-35971 or the next vulnerability affects your stack