What’s Vulnerable › Vulnerabilities
CVE-2023-35979: Unauthenticated Buffer Overflow Vulnerability in ArubaOS Web-Based Management Interface
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-120
Description
There is an unauthenticated buffer overflow vulnerability in the process controlling the ArubaOS web-based management interface. Successful exploitation of this vulnerability results in a Denial-of-Service (DoS) condition affecting the web-based management interface of the controller.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.5.4.0 before 8.6.0.21; from 8.7.0.0 before 8.10.0.7; from 8.11.0.0 before 8.11.1.1; from 10.4.0.0 before 10.4.0.2 — fixed in 10.4.0.2, 8.10.0.7, 8.11.1.1, 8.6.0.21
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.2, 8.10.0.7, 8.11.1.1, 8.6.0.21. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-008.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-008.txt
Get alerted when CVE-2023-35979 or the next vulnerability affects your stack