What’s Vulnerable › Vulnerabilities
CVE-2023-36013: PowerShell Information Disclosure Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-798
Description
PowerShell Information Disclosure Vulnerability
Affected products
- Microsoft Powershell: from 7.2 before 7.2.17; from 7.3 before 7.3.10 — fixed in 7.2.17, 7.3.10
- Microsoft PowerShell 7.2: from 7.2.0 before 7.2.17 — fixed in 7.2.17
- Microsoft PowerShell 7.3: from 7.3.0 before 7.3.10 — fixed in 7.3.10
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.0 — fixed in 7.4.0
How to fix
Upgrade to a fixed version: Microsoft Powershell 7.2.17, 7.3.10; Microsoft PowerShell 7.2 7.2.17; Microsoft PowerShell 7.3 7.3.10; Microsoft PowerShell 7.4 7.4.0. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-36013
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-36013
Get alerted when CVE-2023-36013 or the next vulnerability affects your stack