What’s Vulnerable › Vulnerabilities
CVE-2023-3611: Out-of-bounds write in Linux kernel's net/sched: sch_qfq component
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-21 · updated 2026-10-14
- Weakness: CWE-787
Description
An out-of-bounds write vulnerability in the Linux kernel's net/sched: sch_qfq component can be exploited to achieve local privilege escalation. The qfq_change_agg() function in net/sched/sch_qfq.c allows an out-of-bounds write because lmax is updated according to packet sizes without bounds checks. We recommend upgrading past commit 3e337087c3b5805fe0b8a46ba622a962880b5d64.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- Linux kernel: from 3.8 before 4.14.322; from 4.15 before 4.19.291; from 4.20 before 5.4.253; from 5.5 before 5.10.188; from 5.11 before 5.15.121; from 5.16 before 6.1.40 — fixed in 4.14.322, 4.19.291, 5.10.188, 5.15.121, 5.4.253, 6.1.40
How to fix
Upgrade to a fixed version: Linux kernel 4.14.322, 4.19.291, 5.10.188, 5.15.121. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3e337087c3b5805fe0b8a46ba622a962880b5d64
- https://kernel.dance/3e337087c3b5805fe0b8a46ba622a962880b5d64
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://security.netapp.com/advisory/ntap-20230908-0002/
- https://www.debian.org/security/2023/dsa-5480
- https://www.debian.org/security/2023/dsa-5492
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3e337087c3b5805fe0b8a46ba622a962880b5d64
- https://kernel.dance/3e337087c3b5805fe0b8a46ba622a962880b5d64
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://security.netapp.com/advisory/ntap-20230908-0002/
Get alerted when CVE-2023-3611 or the next vulnerability affects your stack