What’s Vulnerable › Vulnerabilities
CVE-2023-3636: WP Project Manager <= 2.6.4 - Arbitrary Usermeta Update to Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-31 · updated 2026-06-17
- Weakness: CWE-269
Description
The WP Project Manager plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.6.4 due to insufficient restriction on the 'save_users_map_name' function. This makes it possible for authenticated attackers, with minimal permissions such as a subscriber, to modify their user role by supplying the 'usernames' parameter.
Affected products
- wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker: before 2.6.5 — fixed in 2.6.5
How to fix
Upgrade to a fixed version: wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker 2.6.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wedevs-project-manager/tags/2.6.3/src/User/Controllers/User_Controller.php#L158
- https://plugins.trac.wordpress.org/changeset/2942291/wedevs-project-manager#file1792
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6a5e4708-db3e-483c-852f-1a487825cf92?source=cve
- https://plugins.trac.wordpress.org/browser/wedevs-project-manager/tags/2.6.3/src/User/Controllers/User_Controller.php#L158
- https://plugins.trac.wordpress.org/changeset/2942291/wedevs-project-manager#file1792
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6a5e4708-db3e-483c-852f-1a487825cf92?source=cve
Get alerted when CVE-2023-3636 or the next vulnerability affects your stack