What’s Vulnerable › Vulnerabilities
CVE-2023-3645: Contact Form Builder by Bit Form < 2.2.0 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-14 · updated 2026-06-17
Description
The Contact Form Builder by Bit Form WordPress plugin before 2.2.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- bitpressadmin Bit Form – Custom Contact Form, Multi Step, Conversational Form & Payment Form builder: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: bitpressadmin Bit Form – Custom Contact Form, Multi Step, Conversational Form & Payment Form builder 2.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/58c11f1e-6ea0-468c-b974-4aea9eb94b82
- https://wpscan.com/vulnerability/58c11f1e-6ea0-468c-b974-4aea9eb94b82
Get alerted when CVE-2023-3645 or the next vulnerability affects your stack