What’s Vulnerable › Vulnerabilities

CVE-2023-36459: Mastodon vulnerable to Cross-site Scripting through oEmbed preview cards

Description

Mastodon is a free, open-source social network server based on ActivityPub. Starting in version 1.3 and prior to versions 3.5.9, 4.0.5, and 4.1.3, an attacker using carefully crafted oEmbed data can bypass the HTML sanitization performed by Mastodon and include arbitrary HTML in oEmbed preview cards. This introduces a vector for cross-site scripting (XSS) payloads that can be rendered in the user's browser when a preview card for a malicious link is clicked through. Versions 3.5.9, 4.0.5, and 4.1.3 contain a patch for this issue.

Affected products

How to fix

Upgrade to a fixed version: mastodon 3.5.9, 4.0.5, 4.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-36459 or the next vulnerability affects your stack