What’s Vulnerable › Vulnerabilities
CVE-2023-36463: Cross site scripting (XSS) in meldekarten generator
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Meldekarten generator is an open source project to create a program, running locally in the browser without the need for an internet-connection, to create, store and print registration cards for volunteers. All text fields on the webpage are vulnerable to XSS attacks. The user input isn't (fully) sanitized after submission. This issue has been addressed in commit `77e04f4af` which is included in the `1.0.0b1.1.2` release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- jucktnich meldekarten-generator: before 1.0.0b1.1.2 — fixed in 1.0.0b1.1.2
How to fix
Upgrade to a fixed version: jucktnich meldekarten-generator 1.0.0b1.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/jucktnich/meldekarten-generator/commit/77e04f4af85a6d0b08e616d40eaa81877a108c96
- https://github.com/jucktnich/meldekarten-generator/security/advisories/GHSA-f2gp-85cr-vgj7
- https://github.com/jucktnich/meldekarten-generator/commit/77e04f4af85a6d0b08e616d40eaa81877a108c96
- https://github.com/jucktnich/meldekarten-generator/security/advisories/GHSA-f2gp-85cr-vgj7
Get alerted when CVE-2023-36463 or the next vulnerability affects your stack