What’s Vulnerable › Vulnerabilities
CVE-2023-36474: Interactsh server settings make users vulnerable to Subdomain Takeover
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Interactsh is an open-source tool for detecting out-of-band interactions. Domains configured with interactsh server prior to version 1.0.0 were vulnerable to subdomain takeover for a specific subdomain, i.e `app.` Interactsh server used to create cname entries for `app` pointing to `projectdiscovery.github.io` as default, which intended to used for hosting interactsh web client using GitHub pages. This is a security issue with a self-hosted interactsh server in which the user may not have configured a web client but still have a CNAME entry pointing to GitHub pages, making them vulnerable to subdomain takeover. This allows a threat actor to host / run arbitrary client side code (cross-site scripting) in a user's browser when browsing the vulnerable subdomain. Version 1.0.0 fixes this issue by making CNAME optional, rather than default.
Affected products
- projectdiscovery interactsh: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: projectdiscovery interactsh 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/interactsh/issues/136
- https://github.com/projectdiscovery/interactsh/pull/155
- https://github.com/projectdiscovery/interactsh/security/advisories/GHSA-m36x-mgfh-8g78
- https://labs.detectify.com/2014/10/21/hostile-subdomain-takeover-using-herokugithubdesk-more/
- https://github.com/projectdiscovery/interactsh/issues/136
- https://github.com/projectdiscovery/interactsh/pull/155
- https://github.com/projectdiscovery/interactsh/security/advisories/GHSA-m36x-mgfh-8g78
- https://labs.detectify.com/2014/10/21/hostile-subdomain-takeover-using-herokugithubdesk-more/
Get alerted when CVE-2023-36474 or the next vulnerability affects your stack