What’s Vulnerable › Vulnerabilities

CVE-2023-36477: Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform

Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.

Affected products

How to fix

Upgrade to a fixed version: xwiki-contrib application-ckeditor 1.64.9; xwiki-platform 14.10.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-36477 or the next vulnerability affects your stack