What’s Vulnerable › Vulnerabilities
CVE-2023-36479: Jetty vulnerable to errant command quoting in CGI Servlet
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-149
Description
Eclipse Jetty Canonical Repository is the canonical repository for the Jetty project. Users of the CgiServlet with a very specific command structure may have the wrong command executed. If a user sends a request to a org.eclipse.jetty.servlets.CGI Servlet for a binary with a space in its name, the servlet will escape the command by wrapping it in quotation marks. This wrapped command, plus an optional command prefix, will then be executed through a call to Runtime.exec. If the original binary name provided by the user contains a quotation mark followed by a space, the resulting command line will contain multiple tokens instead of one. This issue was patched in version 9.4.52, 10.0.16, 11.0.16 and 12.0.0-beta2.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- The Eclipse Foundation Eclipse Jetty: from 9.0.0 before 9.4.52; from 10.0.0 before 10.0.16; from 11.0.0 before 11.0.16; 12.0.0-alpha1, 12.0.0-alpha2, 12.0.0-alpha3, 12.0.0-beta0, 12.0.0-beta1 — fixed in 10.0.16, 11.0.16, 9.4.52
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 10.0.16, 11.0.16, 9.4.52. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse/jetty.project/pull/9516
- https://github.com/eclipse/jetty.project/pull/9888
- https://github.com/eclipse/jetty.project/pull/9889
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-3gh6-v5v9-6v9j
- https://lists.debian.org/debian-lts-announce/2023/09/msg00039.html
- https://www.debian.org/security/2023/dsa-5507
- https://github.com/eclipse/jetty.project/pull/9516
- https://github.com/eclipse/jetty.project/pull/9888
- https://github.com/eclipse/jetty.project/pull/9889
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-3gh6-v5v9-6v9j
- https://lists.debian.org/debian-lts-announce/2023/09/msg00039.html
- https://www.debian.org/security/2023/dsa-5507
Get alerted when CVE-2023-36479 or the next vulnerability affects your stack