What’s Vulnerable › Vulnerabilities
CVE-2023-36505: WordPress Ninja Forms Plugin <= 3.6.24 is vulnerable to Arbitrary File Deletion
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Saturday Drive Ninja Forms Contact Form.This issue affects Ninja Forms Contact Form : from n/a through 3.6.24.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.6.25 — fixed in 3.6.25
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.6.25. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ninja-forms/wordpress-ninja-forms-contact-form-the-drag-and-drop-form-builder-for-wordpress-plugin-3-6-24-arbitrary-file-deletion-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ninja-forms/wordpress-ninja-forms-contact-form-the-drag-and-drop-form-builder-for-wordpress-plugin-3-6-24-arbitrary-file-deletion-vulnerability?_s_id=cve
Get alerted when CVE-2023-36505 or the next vulnerability affects your stack