What’s Vulnerable › Vulnerabilities
CVE-2023-3662: CODESYS: Vulnerability in CODESYS Development System allows for execution of binaries
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-03 · updated 2026-06-17
- Weakness: CWE-427
Description
In CODESYS Development System versions from 3.5.17.0 and prior to 3.5.19.20 a vulnerability allows for execution of binaries from the current working directory in the users context .
Affected products
- CODESYS Development System: from 3.5.17.0 before 3.5.19.20 — fixed in 3.5.19.20
How to fix
Upgrade to a fixed version: CODESYS Development System 3.5.19.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-3662 or the next vulnerability affects your stack