What’s Vulnerable › Vulnerabilities
CVE-2023-36656
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in Jaegertracing Jaeger UI before v.1.31.0 allows a remote attacker to execute arbitrary code via the KeyValuesTable component.
Affected products
- Jaegertracing Jaeger Ui: before 1.31.0 — fixed in 1.31.0
How to fix
Upgrade to a fixed version: Jaegertracing Jaeger Ui 1.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/jaegertracing/jaeger-ui/pull/1498
- https://github.com/jaegertracing/jaeger-ui/security/advisories/GHSA-vv24-rm95-q56r
- https://github.com/mafintosh/json-markup/pull/15
- https://github.com/jaegertracing/jaeger-ui/pull/1498
- https://github.com/jaegertracing/jaeger-ui/security/advisories/GHSA-vv24-rm95-q56r
- https://github.com/mafintosh/json-markup/pull/15
Get alerted when CVE-2023-36656 or the next vulnerability affects your stack