What’s Vulnerable › Vulnerabilities
CVE-2023-36658
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-428
Description
An issue was discovered in OPSWAT MetaDefender KIOSK 4.6.1.9996. It has an unquoted service path that can be abused locally.
Affected products
- OPSWAT Media Validation Agent: from 2.0.0 before 2.0.7 — fixed in 2.0.7
- OPSWAT MetaDefender Kiosk: from 4.2 before 4.6.2 — fixed in 4.6.2
How to fix
Upgrade to a fixed version: OPSWAT Media Validation Agent 2.0.7; OPSWAT MetaDefender Kiosk 4.6.2. Check the vendor advisory for mitigations.
References
- https://docs.opswat.com/mdkiosk
- https://docs.opswat.com/mdkiosk/release-notes/cve-2023-36658
- https://docs.opswat.com/mdkiosk
- https://docs.opswat.com/mdkiosk/release-notes/cve-2023-36658
Get alerted when CVE-2023-36658 or the next vulnerability affects your stack