What’s Vulnerable › Vulnerabilities
CVE-2023-36664
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-25 · updated 2026-08-28
- Weakness: CWE-552
Description
Artifex Ghostscript before 10.01.2 mishandles permission validation for pipe devices (with the %pipe% prefix or the | pipe character prefix).
Affected products
- Artifex Ghostscript: before 10.01.2 — fixed in 10.01.2
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 37, 38
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.01.2. Check the vendor advisory for mitigations.
References
- https://artifex.com/blog/security-vulnerability-fixed-in-ghostscript-10.01.2
- https://bugs.ghostscript.com/show_bug.cgi?id=706761
- https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=0974e4f2ac0005d3731e0b5c13ebc7e965540f4d
- https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=505eab7782b429017eb434b2b95120855f2b0e3c
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2ICXN5VPF3WJCYKMPSYER5KHTPJXSTJZ/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5EWMEK2UPCUU3ZLL7VASE5CEHDQY4VKV/
- https://security-tracker.debian.org/tracker/CVE-2023-36664
- https://security.gentoo.org/glsa/202309-03
- https://www.debian.org/security/2023/dsa-5446
- https://www.kroll.com/en/publications/cyber/ghostscript-cve-2023-36664-remote-code-execution-vulnerability
- https://bugs.ghostscript.com/show_bug.cgi?id=706761
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=0974e4f2ac0005d3731e0b5c13ebc7e965540f4d
Get alerted when CVE-2023-36664 or the next vulnerability affects your stack