What’s Vulnerable › Vulnerabilities
CVE-2023-3672: Cross-site Scripting (XSS) - DOM in plaidweb/webmention.js
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository plaidweb/webmention.js prior to 0.5.5.
Affected products
- plaidweb/webmention.js: before 0.5.5 — fixed in 0.5.5
How to fix
Upgrade to a fixed version: plaidweb/webmention.js 0.5.5. Check the vendor advisory for mitigations.
References
- https://github.com/plaidweb/webmention.js/commit/3551b66b3e40da37fee89ecf72930c5efdc53011
- https://huntr.dev/bounties/75cfb7ad-a75f-45ff-8688-32a9c55179aa
- https://github.com/plaidweb/webmention.js/commit/3551b66b3e40da37fee89ecf72930c5efdc53011
- https://huntr.dev/bounties/75cfb7ad-a75f-45ff-8688-32a9c55179aa
Get alerted when CVE-2023-3672 or the next vulnerability affects your stack