What’s Vulnerable › Vulnerabilities

CVE-2023-36806: Contao cross site scripting vulnerability via input unit widget

Description

Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

Affected products

How to fix

Upgrade to a fixed version: contao 4.13.28, 4.9.42, 5.1.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-36806 or the next vulnerability affects your stack