What’s Vulnerable › Vulnerabilities
CVE-2023-36813: Kanboard Authenticated SQL Injections vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-89
Description
Kanboard is project management software that focuses on the Kanban methodology. In versions prior to 1.2.31authenticated user is able to perform a SQL Injection, leading to a privilege escalation or loss of confidentiality. It appears that in some insert and update operations, the code improperly uses the PicoDB library to update/insert new information. Version 1.2.31 contains a fix for this issue.
Affected products
- kanboard: before 1.2.31 — fixed in 1.2.31
How to fix
Upgrade to a fixed version: kanboard 1.2.31. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/commit/25b93343baeaf8ad018dcd87b094e47a5c6a3e0a
- https://github.com/kanboard/kanboard/releases/tag/v1.2.31
- https://github.com/kanboard/kanboard/security/advisories/GHSA-9gvq-78jp-jxcx
- https://www.debian.org/security/2023/dsa-5454
- https://github.com/kanboard/kanboard/commit/25b93343baeaf8ad018dcd87b094e47a5c6a3e0a
- https://github.com/kanboard/kanboard/releases/tag/v1.2.31
- https://github.com/kanboard/kanboard/security/advisories/GHSA-9gvq-78jp-jxcx
- https://www.debian.org/security/2023/dsa-5454
Get alerted when CVE-2023-36813 or the next vulnerability affects your stack