What’s Vulnerable › Vulnerabilities
CVE-2023-36816: Cross-Site Scripting (XSS) at Account creation in 2FAuth
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-03 · updated 2026-06-17
- Weakness: CWE-79
Description
2FA is a Web app to manage Two-Factor Authentication (2FA) accounts and generate their security codes. Cross site scripting (XSS) injection can be done via the account/service field. This was tested in docker-compose environment. This vulnerability has been patched in version 4.0.3.
Affected products
- Bubka 2FAuth: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Bubka 2FAuth 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/Bubka/2FAuth/releases/tag/v4.0.3
- https://github.com/Bubka/2FAuth/security/advisories/GHSA-cwhq-2mcq-pp9q
- https://github.com/Bubka/2FAuth/releases/tag/v4.0.3
- https://github.com/Bubka/2FAuth/security/advisories/GHSA-cwhq-2mcq-pp9q
Get alerted when CVE-2023-36816 or the next vulnerability affects your stack