What’s Vulnerable › Vulnerabilities
CVE-2023-36822: Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-22
Description
Uptime Kuma, a self-hosted monitoring tool, has a path traversal vulnerability in versions prior to 1.22.1. Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. Before a plugin is downloaded, the plugin installation directory is checked for existence. If it exists, it's removed before the plugin installation. Because the plugin is not validated against the official list of plugins or sanitized, the check for existence and the removal of the plugin installation directory are prone to path traversal. This vulnerability allows an authenticated attacker to delete files from the server Uptime Kuma is running on. Depending on which files are deleted, Uptime Kuma or the whole system may become unavailable due to data loss.
Affected products
- louislam uptime-kuma: before 1.22.1 — fixed in 1.22.1
How to fix
Upgrade to a fixed version: louislam uptime-kuma 1.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/louislam/uptime-kuma/blob/de74efb2e6601dcbcfed32cddefc4078a80fcb0b/server/plugins-manager.js#L75-L80
- https://github.com/louislam/uptime-kuma/pull/3346
- https://github.com/louislam/uptime-kuma/releases/tag/1.22.1
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-vr8x-74pm-6vj7
- https://github.com/louislam/uptime-kuma/blob/de74efb2e6601dcbcfed32cddefc4078a80fcb0b/server/plugins-manager.js#L75-L80
- https://github.com/louislam/uptime-kuma/pull/3346
- https://github.com/louislam/uptime-kuma/releases/tag/1.22.1
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-vr8x-74pm-6vj7
Get alerted when CVE-2023-36822 or the next vulnerability affects your stack