What’s Vulnerable › Vulnerabilities
CVE-2023-36823: Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Sanitize is an allowlist-based HTML and CSS sanitizer. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML and CSS through Sanitize starting with version 3.0.0 and prior to version 6.0.2 when Sanitize is configured to use the built-in "relaxed" config or when using a custom config that allows `style` elements and one or more CSS at-rules. This could result in cross-site scripting or other undesired behavior when the malicious HTML and CSS are rendered in a browser. Sanitize 6.0.2 performs additional escaping of CSS in `style` element content, which fixes this issue. Users who are unable to upgrade can prevent this issue by using a Sanitize config that doesn't allow `style` elements, using a Sanitize config that doesn't allow CSS at-rules, or by manually escaping the character sequence `</` as `<\/` in `style` element content.
Affected products
- Debian Linux: 10.0
- rgrove sanitize: from 3.0.0 before 6.0.2 — fixed in 6.0.2
- Rubygems Sanitize: from 3.0.0 before 6.0.2; 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.1.0 (+24) — fixed in 6.0.2
How to fix
Upgrade to a fixed version: rgrove sanitize 6.0.2; Rubygems Sanitize 6.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/rgrove/sanitize/commit/76ed46e6dc70820f38efe27de8dabd54dddb5220
- https://github.com/rgrove/sanitize/releases/tag/v6.0.2
- https://github.com/rgrove/sanitize/security/advisories/GHSA-f5ww-cq3m-q3g7
- https://lists.debian.org/debian-lts-announce/2023/11/msg00008.html
- https://github.com/rgrove/sanitize/commit/76ed46e6dc70820f38efe27de8dabd54dddb5220
- https://github.com/rgrove/sanitize/releases/tag/v6.0.2
- https://github.com/rgrove/sanitize/security/advisories/GHSA-f5ww-cq3m-q3g7
- https://lists.debian.org/debian-lts-announce/2023/11/msg00008.html
Get alerted when CVE-2023-36823 or the next vulnerability affects your stack