What’s Vulnerable › Vulnerabilities
CVE-2023-36825: Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-502
Description
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.
Affected products
- orchidsoftware platform: from 14.0.1 before 14.5.0; 14.0.0, 14.0.0-alpha4, 14.0.0-alpha5, 14.0.0-alpha6, 14.0.0-alpha7 — fixed in 14.5.0
How to fix
Upgrade to a fixed version: orchidsoftware platform 14.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/orchidsoftware/platform/releases/tag/14.5.0
- https://github.com/orchidsoftware/platform/security/advisories/GHSA-ph6g-p72v-pc3p
- https://github.com/orchidsoftware/platform/releases/tag/14.5.0
- https://github.com/orchidsoftware/platform/security/advisories/GHSA-ph6g-p72v-pc3p
Get alerted when CVE-2023-36825 or the next vulnerability affects your stack