What’s Vulnerable › Vulnerabilities
CVE-2023-36826: Sentry vulnerable to improper authorization on debug and artifact file downloads
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-285
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
Affected products
- getsentry sentry: from 8.21.0 before 23.5.2 — fixed in 23.5.2
How to fix
Upgrade to a fixed version: getsentry sentry 23.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry/commit/e932b15435bf36239431eaa3790a6bcfa47046a9
- https://github.com/getsentry/sentry/pull/49680
- https://github.com/getsentry/sentry/security/advisories/GHSA-m4hc-m2v6-hfw8
- https://github.com/getsentry/sentry/commit/e932b15435bf36239431eaa3790a6bcfa47046a9
- https://github.com/getsentry/sentry/pull/49680
- https://github.com/getsentry/sentry/security/advisories/GHSA-m4hc-m2v6-hfw8
Get alerted when CVE-2023-36826 or the next vulnerability affects your stack