What’s Vulnerable › Vulnerabilities
CVE-2023-36827: Fides vulnerable to Path Traversal in Webserver API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-22
Description
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.
Affected products
- ethyca fides: before 2.15.1 — fixed in 2.15.1
How to fix
Upgrade to a fixed version: ethyca fides 2.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f
- https://github.com/ethyca/fides/releases/tag/2.15.1
- https://github.com/ethyca/fides/security/advisories/GHSA-r25m-cr6v-p9hq
- https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f
- https://github.com/ethyca/fides/releases/tag/2.15.1
- https://github.com/ethyca/fides/security/advisories/GHSA-r25m-cr6v-p9hq
Get alerted when CVE-2023-36827 or the next vulnerability affects your stack