What’s Vulnerable › Vulnerabilities
CVE-2023-36829: Sentry CORS misconfiguration vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-06 · updated 2026-06-17
- Weakness: CWE-863
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 23.6.0 and prior to version 23.6.2, the Sentry API incorrectly returns the `access-control-allow-credentials: true` HTTP header if the `Origin` request header ends with the `system.base-hostname` option of Sentry installation. This only affects installations that have `system.base-hostname` option explicitly set, as it is empty by default. Impact is limited since recent versions of major browsers have cross-site cookie blocking enabled by default. However, this flaw could allow other multi-step attacks. The patch has been released in Sentry 23.6.2.
Affected products
- Functional Sentry: from 23.6.0 before 23.6.2 — fixed in 23.6.2
How to fix
Upgrade to a fixed version: Functional Sentry 23.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted/releases/tag/23.6.2
- https://github.com/getsentry/sentry/commit/ee44c6be35e5e464bc40637580f39867898acd8b
- https://github.com/getsentry/sentry/pull/52276
- https://github.com/getsentry/sentry/security/advisories/GHSA-4xqm-4p72-87h6
- https://github.com/getsentry/self-hosted/releases/tag/23.6.2
- https://github.com/getsentry/sentry/commit/ee44c6be35e5e464bc40637580f39867898acd8b
- https://github.com/getsentry/sentry/pull/52276
- https://github.com/getsentry/sentry/security/advisories/GHSA-4xqm-4p72-87h6
Get alerted when CVE-2023-36829 or the next vulnerability affects your stack