What’s Vulnerable › Vulnerabilities
CVE-2023-36840: Junos OS and Junos OS Evolved: An rpd crash occurs when a specific L2VPN command is run
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-14 · updated 2026-06-17
- Weakness: CWE-617
Description
A Reachable Assertion vulnerability in Routing Protocol Daemon (RPD) of Juniper Networks Junos OS and Junos OS Evolved allows a locally-based, low-privileged attacker to cause a Denial of Service (DoS). On all Junos OS and Junos OS Evolved, when a specific L2VPN command is run, RPD will crash and restart. Continued execution of this specific command will create a sustained Denial of Service (DoS) condition. This issue affects: Juniper Networks Junos OS All versions prior to 19.3R3-S10; 20.1 versions prior to 20.1R3-S4; 20.2 versions prior to 20.2R3-S6; 20.3 versions prior to 20.3R3-S6; 20.4 versions prior to 20.4R3-S5; 21.1 versions prior to 21.1R3-S4; 21.2 versions prior to 21.2R3-S3; 21.3 versions prior to 21.3R3-S2; 21.4 versions prior to 21.4R3; 22.1 versions prior to 22.1R3; 22.2 versions prior to 22.2R2; 22.3 versions prior to 22.3R2; Juniper Networks Junos OS Evolved All versions prior to 20.4R3-S7-EVO; 21.1 versions prior to 21.1R3-S3-EVO; 21.2 versions prior to 21.2R3-S5-EVO; 21.3 versions prior to 21.3R3-S4-EVO; 21.4 versions prior to 21.4R3-EVO; 22.1 versions prior to 22.1R3-EVO; 22.2 versions prior to 22.2R2-EVO; 22.3 versions prior to 22.3R2-EVO;
Affected products
- Juniper Junos OS: before 19.3; 19.3, 19.3-r1, 19.3-r1-s1, 19.3-r2, 19.3-r2-s1, 19.3-r2-s2 (+135) — fixed in 19.3
- Juniper Networks Junos OS Evolved: before 20.4; 20.4, 20.4-r1, 20.4-r1-s1, 20.4-r1-s2, 20.4-r2, 20.4-r2-s1 (+55) — fixed in 20.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 19.3; Juniper Networks Junos OS Evolved 20.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-36840 or the next vulnerability affects your stack