What’s Vulnerable › Vulnerabilities
CVE-2023-3691: layui HTML Attribute cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16. This affects an unknown part of the component HTML Attribute Handler. The manipulation of the argument title leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.8.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-234237 was assigned to this vulnerability.
Affected products
- layui: before 2.8.0; 2.8.0-beta1, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-rc1, 2.8.0-rc10, 2.8.0-rc11 (+13) — fixed in 2.8.0
How to fix
Upgrade to a fixed version: layui 2.8.0. Check the vendor advisory for mitigations.
References
- https://gitee.com/layui/layui/issues/I7HDXZ
- https://gitee.com/layui/layui/tree/v2.8.0
- https://vuldb.com/?ctiid.234237
- https://vuldb.com/?id.234237
- https://gitee.com/layui/layui/issues/I7HDXZ
- https://gitee.com/layui/layui/tree/v2.8.0
- https://vuldb.com/?ctiid.234237
- https://vuldb.com/?id.234237
Get alerted when CVE-2023-3691 or the next vulnerability affects your stack