What’s Vulnerable › Vulnerabilities
CVE-2023-3707: ActivityPub for WordPress < 1.0.0 - Subscriber+ Arbitrary Post Content Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
Description
The ActivityPub WordPress plugin before 1.0.0 does not ensure that post contents to be displayed are public and belong to the plugin, allowing any authenticated user, such as subscriber to retrieve the content of arbitrary post (such as draft and private) via an IDOR vector. Password protected posts are not affected by this issue.
Affected products
- ActivityPub: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: ActivityPub 1.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/541bbe4c-3295-4073-901d-763556269f48
- https://wpscan.com/vulnerability/541bbe4c-3295-4073-901d-763556269f48
Get alerted when CVE-2023-3707 or the next vulnerability affects your stack