What’s Vulnerable › Vulnerabilities
CVE-2023-37154
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-06-17
- Weakness: CWE-77
Description
check_by_ssh in Nagios nagios-plugins 2.4.5 allows arbitrary command execution via ProxyCommand, LocalCommand, and PermitLocalCommand with \${IFS}. This has been categorized both as fixed in e8810de, and as intended behavior.
Affected products
- Nagios Plugins: before 2.4.5 — fixed in 2.4.5
How to fix
Upgrade to a fixed version: Nagios Plugins 2.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/monitoring-plugins/monitoring-plugins/security/advisories/GHSA-p3gv-vmpx-hhw4
- https://github.com/nagios-plugins/nagios-plugins/commit/e8810de21be80148562b7e0168b0a62aeedffde6
- https://joshua.hu/nagios-hacking-cve-2023-37154
Get alerted when CVE-2023-37154 or the next vulnerability affects your stack