What’s Vulnerable › Vulnerabilities
CVE-2023-3724: TLS 1.3 client issue handling malicious server when not including a KSE and PSK extension
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-17 · updated 2026-06-17
- Weakness: CWE-20
Description
If a TLS 1.3 client gets neither a PSK (pre shared key) extension nor a KSE (key share extension) when connecting to a malicious server, a default predictable buffer gets used for the IKM (Input Keying Material) value when generating the session master secret. Using a potentially known IKM value when generating the session master secret key compromises the key generated, allowing an eavesdropper to reconstruct it and potentially allowing access to or meddling with message contents in the session. This issue does not affect client validation of connected servers, nor expose private key information, but could result in an insecure TLS 1.3 session when not controlling both sides of the connection. wolfSSL recommends that TLS 1.3 client side users update the version of wolfSSL used.
Affected products
- wolfSSL: before 5.6.2 — fixed in 5.6.2
How to fix
Upgrade to a fixed version: wolfSSL 5.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/6412
- https://www.wolfssl.com/docs/security-vulnerabilities/
- https://github.com/wolfSSL/wolfssl/pull/6412
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2023-3724 or the next vulnerability affects your stack