What’s Vulnerable › Vulnerabilities
CVE-2023-37257: The DataEase panel and dataset have a stored XSS vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
DataEase is an open source data visualization analysis tool. Prior to version 1.18.9, the DataEase panel and dataset have a stored cross-site scripting vulnerability. The vulnerability has been fixed in v1.18.9. There are no known workarounds.
Affected products
- dataease: before 1.18.9 — fixed in 1.18.9
How to fix
Upgrade to a fixed version: dataease 1.18.9. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/releases/tag/v1.18.9
- https://github.com/dataease/dataease/security/advisories/GHSA-7cm3-9pp6-q2fq
- https://github.com/dataease/dataease/releases/tag/v1.18.9
- https://github.com/dataease/dataease/security/advisories/GHSA-7cm3-9pp6-q2fq
Get alerted when CVE-2023-37257 or the next vulnerability affects your stack