What’s Vulnerable › Vulnerabilities
CVE-2023-37258: DataEase has a SQL injection vulnerability that can bypass blacklists
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-89
Description
DataEase is an open source data visualization analysis tool. Prior to version 1.18.9, DataEase has a SQL injection vulnerability that can bypass blacklists. The vulnerability has been fixed in v1.18.9. There are no known workarounds.
Affected products
- dataease: before 1.18.9 — fixed in 1.18.9
How to fix
Upgrade to a fixed version: dataease 1.18.9. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/blob/dev/backend/src/main/java/io/dataease/controller/panel/AppLogController.java#L41
- https://github.com/dataease/dataease/blob/dev/backend/src/main/java/io/dataease/ext/ExtDataSourceMapper.java
- https://github.com/dataease/dataease/security/advisories/GHSA-r39x-fcc6-47g4
- https://github.com/dataease/dataease/blob/dev/backend/src/main/java/io/dataease/controller/panel/AppLogController.java#L41
- https://github.com/dataease/dataease/blob/dev/backend/src/main/java/io/dataease/ext/ExtDataSourceMapper.java
- https://github.com/dataease/dataease/security/advisories/GHSA-r39x-fcc6-47g4
Get alerted when CVE-2023-37258 or the next vulnerability affects your stack