What’s Vulnerable › Vulnerabilities
CVE-2023-37273: Docker escape in Auto-GPT when running from docker-compose.yml included in git repo
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-94
Description
Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. Running Auto-GPT version prior to 0.4.3 by cloning the git repo and executing `docker compose run auto-gpt` in the repo root uses a different docker-compose.yml file from the one suggested in the official docker set up instructions. The docker-compose.yml file located in the repo root mounts itself into the docker container without write protection. This means that if malicious custom python code is executed via the `execute_python_file` and `execute_python_code` commands, it can overwrite the docker-compose.yml file and abuse it to gain control of the host system the next time Auto-GPT is started. The issue has been patched in version 0.4.3.
Affected products
- Agpt Autogpt Classic: before 0.4.3 — fixed in 0.4.3
How to fix
Upgrade to a fixed version: Agpt Autogpt Classic 0.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/Significant-Gravitas/Auto-GPT/pull/4761
- https://github.com/Significant-Gravitas/Auto-GPT/security/advisories/GHSA-x5gj-2chr-4ch6
- https://github.com/Significant-Gravitas/Auto-GPT/pull/4761
- https://github.com/Significant-Gravitas/Auto-GPT/security/advisories/GHSA-x5gj-2chr-4ch6
Get alerted when CVE-2023-37273 or the next vulnerability affects your stack