What’s Vulnerable › Vulnerabilities
CVE-2023-37275: System logs spoofable in Auto-GPT via ANSI control sequences
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-117
Description
Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. The Auto-GPT command line UI makes heavy use of color-coded print statements to signify different types of system messages to the user, including messages that are crucial for the user to review and control which commands should be executed. Before v0.4.3, it was possible for a malicious external resource (such as a website browsed by Auto-GPT) to cause misleading messages to be printed to the console by getting the LLM to regurgitate JSON encoded ANSI escape sequences (`\u001b[`). These escape sequences were JSON decoded and printed to the console as part of the model's "thinking process". The issue has been patched in release version 0.4.3.
Affected products
- Agpt Autogpt Classic: before 0.4.3 — fixed in 0.4.3
How to fix
Upgrade to a fixed version: Agpt Autogpt Classic 0.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/Significant-Gravitas/Auto-GPT/pull/4810
- https://github.com/Significant-Gravitas/Auto-GPT/security/advisories/GHSA-r7f7-qrrv-3fjh
- https://github.com/Significant-Gravitas/Auto-GPT/pull/4810
- https://github.com/Significant-Gravitas/Auto-GPT/security/advisories/GHSA-r7f7-qrrv-3fjh
Get alerted when CVE-2023-37275 or the next vulnerability affects your stack