What’s Vulnerable › Vulnerabilities
CVE-2023-37280: Pimcore admin UI vulnerable to Cross-site Scripting in two factor authentication setup page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Pimcore Admin Classic Bundle provides a Backend UI for Pimcore based on the ExtJS framework. An admin who has not setup two factor authentication before is vulnerable for this attack, without need for any form of privilege, causing the application to execute arbitrary scripts/HTML content. This vulnerability has been patched in version 1.0.3.
Affected products
- pimcore admin-ui-classic-bundle: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/commit/5fcd19bdc89a3fe4cb8ad8c356590e1e4740c743
- https://github.com/pimcore/admin-ui-classic-bundle/pull/147
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-hqv9-6jqw-9g8m
- https://github.com/pimcore/admin-ui-classic-bundle/commit/5fcd19bdc89a3fe4cb8ad8c356590e1e4740c743
- https://github.com/pimcore/admin-ui-classic-bundle/pull/147
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-hqv9-6jqw-9g8m
Get alerted when CVE-2023-37280 or the next vulnerability affects your stack