What’s Vulnerable › Vulnerabilities
CVE-2023-37415: Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider. Patching on top of CVE-2023-35797 Before 6.1.2 the proxy_user option can also inject semicolon. This issue affects Apache Airflow Apache Hive Provider: before 6.1.2. It is recommended updating provider version to 6.1.2 in order to avoid this vulnerability.
Affected products
- Apache Software Foundation Apache Airflow Hive Provider: before 6.1.2 — fixed in 6.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Hive Provider 6.1.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/07/12/3
- https://lists.apache.org/thread/9wx0jlckbnycjh8nj5qfwxo423zvm41k
- http://www.openwall.com/lists/oss-security/2023/07/12/3
- https://lists.apache.org/thread/9wx0jlckbnycjh8nj5qfwxo423zvm41k
Get alerted when CVE-2023-37415 or the next vulnerability affects your stack