What’s Vulnerable › Vulnerabilities
CVE-2023-37470: Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-94
Description
Metabase is an open-source business intelligence and analytics platform. Prior to versions 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4, 1.43.7.3, 1.44.7.3, 1.45.4.3, and 1.46.6.4, a vulnerability could potentially allow remote code execution on one's Metabase server. The core issue is that one of the supported data warehouses (an embedded in-memory database H2), exposes a number of ways for a connection string to include code that is then executed by the process running the embedded database. Because Metabase allows users to connect to databases, this means that a user supplied string can be used to inject executable code. Metabase allows users to validate their connection string before adding a database (including on setup), and this validation API was the primary vector used as it can be called without validation. Versions 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4, 1.43.7.3, 1.44.7.3, 1.45.4.3, and 1.46.6.4 fix this issue by removing the ability of users to add H2 databases entirely. As a workaround, it is possible to block these vulnerabilities at the network level by blocking the endpoints `POST /api/database`, `PUT /api/database/:id`, and `POST /api/setup/validateuntil`. Those who use H2 as a file-based database should migrate to SQLite.
Affected products
- metabase: before 0.43.7.3; before 1.43.7.3; from 0.44.0 before 0.44.7.3; from 0.45.0 before 0.45.4.3; from 0.46.0 before 0.46.6.4; from 1.44.0 before 1.44.7.3 — fixed in 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4, 1.43.7.3, 1.44.7.3
How to fix
Upgrade to a fixed version: metabase 0.43.7.3, 0.44.7.3, 0.45.4.3, 0.46.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/metabase/metabase/security/advisories/GHSA-p7w3-9m58-rq83
- https://github.com/metabase/metabase/security/advisories/GHSA-p7w3-9m58-rq83
Get alerted when CVE-2023-37470 or the next vulnerability affects your stack