What’s Vulnerable › Vulnerabilities
CVE-2023-37475: Attacker-controlled parameter can cause denial of service in hamba avro
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-17 · updated 2026-06-17
- Weakness: CWE-400
Description
Hamba avro is a go lang encoder/decoder implementation of the avro codec specification. In affected versions a well-crafted string passed to avro's `github.com/hamba/avro/v2.Unmarshal()` can throw a `fatal error: runtime: out of memory` which is unrecoverable and can cause denial of service of the consumer of avro. The root cause of the issue is that avro uses part of the input to `Unmarshal()` to determine the size when creating a new slice and hence an attacker may consume arbitrary amounts of memory which in turn may cause the application to crash. This issue has been addressed in commit `b4a402f4` which has been included in release version `2.13.0`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- hamba avro: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: hamba avro 2.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/hamba/avro/commit/b4a402f41cf44b6094b5131286830ba9bb1eb290
- https://github.com/hamba/avro/security/advisories/GHSA-9x44-9pgq-cf45
- https://github.com/hamba/avro/commit/b4a402f41cf44b6094b5131286830ba9bb1eb290
- https://github.com/hamba/avro/security/advisories/GHSA-9x44-9pgq-cf45
Get alerted when CVE-2023-37475 or the next vulnerability affects your stack