What’s Vulnerable › Vulnerabilities
CVE-2023-37477: Command injection in firewall ip functionality in 1Panel
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-78
Description
1Panel is an open source Linux server operation and maintenance management panel. An OS command injection vulnerability exists in 1Panel firewall functionality. A specially-crafted HTTP request can lead to arbitrary command execution. An attacker can make an authenticated HTTP request to trigger this vulnerability. 1Panel firewall functionality `/hosts/firewall/ip` endpoint read user input without validation, the attacker extends the default functionality of the application, which execute system commands. An attacker can execute arbitrary code on the target system, which can lead to a complete compromise of the system. This issue has been addressed in commit `e17b80cff49` which is included in release version `1.4.3`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- 1Panel-dev 1Panel: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: 1Panel-dev 1Panel 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/1Panel/commit/e17b80cff4975ee343568ff526b62319f499005d
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-p9xf-74xh-mhw5
- https://github.com/1Panel-dev/1Panel/commit/e17b80cff4975ee343568ff526b62319f499005d
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-p9xf-74xh-mhw5
Get alerted when CVE-2023-37477 or the next vulnerability affects your stack