What’s Vulnerable › Vulnerabilities
CVE-2023-37478: pnpm incorrectly parses tar archives relative to specification
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-01 · updated 2026-06-17
- Weakness: CWE-284
Description
pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.
Affected products
- pnpm: before 7.33.4; from 8.0.0 before 8.6.8 — fixed in 7.33.4, 8.6.8
How to fix
Upgrade to a fixed version: pnpm 7.33.4, 8.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/releases/tag/v7.33.4
- https://github.com/pnpm/pnpm/releases/tag/v8.6.8
- https://github.com/pnpm/pnpm/security/advisories/GHSA-5r98-f33j-g8h7
- https://github.com/pnpm/pnpm/releases/tag/v7.33.4
- https://github.com/pnpm/pnpm/releases/tag/v8.6.8
- https://github.com/pnpm/pnpm/security/advisories/GHSA-5r98-f33j-g8h7
Get alerted when CVE-2023-37478 or the next vulnerability affects your stack