What’s Vulnerable › Vulnerabilities
CVE-2023-37481: Fides Webserver Vulnerable to SVG Bomb File Uploads
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-400
Description
Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading.
Affected products
- ethyca fides: from 2.11.0 before 2.16.0 — fixed in 2.16.0
How to fix
Upgrade to a fixed version: ethyca fides 2.16.0. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/8beaace082b325e693dc7682029a3cb7e6c2b69d
- https://github.com/ethyca/fides/security/advisories/GHSA-3rw2-wfc8-wmj5
- https://github.com/ethyca/fides/commit/8beaace082b325e693dc7682029a3cb7e6c2b69d
- https://github.com/ethyca/fides/security/advisories/GHSA-3rw2-wfc8-wmj5
Get alerted when CVE-2023-37481 or the next vulnerability affects your stack