What’s Vulnerable › Vulnerabilities
CVE-2023-37503: A weak password requirements vulnerability affects HCL Compass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-521
Description
HCL Compass is vulnerable to insecure password requirements. An attacker could easily guess the password and gain access to user accounts.
Affected products
- HCL Software HCL Compass: from 2.0.0 through 2.0.3; from 2.2.0 before 2.2.3; 2.1.0 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: HCL Software HCL Compass 2.2.3. Check the vendor advisory for mitigations.
References
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107512
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107512
Get alerted when CVE-2023-37503 or the next vulnerability affects your stack