What’s Vulnerable › Vulnerabilities
CVE-2023-37504: An insufficient session expiration vulnerability affects HCL Compass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-613
Description
HCL Compass is vulnerable to failure to invalidate sessions. The application does not invalidate authenticated sessions when the log out functionality is called. If the session identifier can be discovered, it could be replayed to the application and used to impersonate the user.
Affected products
- HCL Software HCL Compass: from 2.0.0 through 2.0.3; from 2.2.0 before 2.2.3; 2.1.0 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: HCL Software HCL Compass 2.2.3. Check the vendor advisory for mitigations.
References
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107511
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107511
Get alerted when CVE-2023-37504 or the next vulnerability affects your stack