What’s Vulnerable › Vulnerabilities
CVE-2023-37534: HCL Leap is affected by a Cross-site scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Insufficient URI protocol whitelist in HCL Leap allows script injection through query parameters.
Affected products
- HCL Software HCL Leap: before 9.3.4 — fixed in 9.3.4
How to fix
Upgrade to a fixed version: HCL Software HCL Leap 9.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-37534 or the next vulnerability affects your stack