What’s Vulnerable › Vulnerabilities
CVE-2023-37544: Apache Pulsar WebSocket Proxy: Improper Authentication for WebSocket Proxy Endpoint Allows DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-20 · updated 2026-06-17
- Weakness: CWE-287
Description
Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.
Affected products
- Apache Software Foundation Apache Pulsar: before 2.10.5; from 2.11.0 before 2.11.2; 3.0.0 — fixed in 2.10.5, 2.11.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.10.5, 2.11.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/12/20/2
- https://lists.apache.org/thread/od0k9zts1toc9h9snbqq4pjpyx28mv4m
- http://www.openwall.com/lists/oss-security/2023/12/20/2
- https://lists.apache.org/thread/od0k9zts1toc9h9snbqq4pjpyx28mv4m
Get alerted when CVE-2023-37544 or the next vulnerability affects your stack