What’s Vulnerable › Vulnerabilities
CVE-2023-37581: Apache Roller: Roller's weblog category, weblog settings and file-upload features did not properly sanitize input could be exploited to perform Reflected Cross Site Scripting (XSS) even on a Roller site configured for untrusted users.
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Insufficient input validation and sanitation in Weblog Category name, Website About and File Upload features in all versions of Apache Roller on all platforms allows an authenticated user to perform an XSS attack. Mitigation: if you do not have Roller configured for untrusted users, then you need to do nothing because you trust your users to author raw HTML and other web content. If you are running with untrusted users then you should upgrade to Roller 6.1.2 and you should disable Roller's File Upload feature.
Affected products
- Apache Software Foundation Apache Roller: before 6.1.2 — fixed in 6.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Roller 6.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n9mjhhlm7z7b7to646tkvf3otkf21flp
- https://www.openwall.com/lists/oss-security/2023/08/16/1
- https://lists.apache.org/thread/n9mjhhlm7z7b7to646tkvf3otkf21flp
- https://www.openwall.com/lists/oss-security/2023/08/16/1
Get alerted when CVE-2023-37581 or the next vulnerability affects your stack